Category Archives: Reference

Windows Hyper-V Errors with Backup Exec & Tape Drive

When running Symantec Backup Exec 2010 R3 with a Quantum tape drive on Windows Server 2012 R2 with Hyper-V, I discovered a problem when starting Hyper-V guests and/or managing VHDs.

Symptom

When attempting to start a VM, the VM failed to start with an error like this:

‘<VM Name>’ failed to start.

Microsoft Emulated IDE Controller (Instance ID {########-####-####-####-############}): Failed to Power on with Error: ‘A device attached to the system is not functioning.’

Failed to open attachment ‘Drive Letter:\path\Virtual Hard drivers\VMNAME_########-####-####-####-############.vhd’. Error: ‘A device attached to the system is not functioning”VM NAME’ failed to start (Virtual Machine ID ########-####-####-####-############)

‘VM NAME’ Microsoft Emulated IDE Controller (Instance ID {########-####-####-####-############}): Failed to Power on with Error: ‘A device attached to the system is not functioning.’ (0x8007001F) (Virtual Machine ID: ########-####-####-####-############)

‘VM NAME’: Failed to open attachment ‘Drive Letter:\path\Virtual Hard drivers\VMNAME_########-####-####-####-############.vhd’. Error: ‘A device attached to the system is not functioning’ (0x8007001F) (Virtual Machine ID: ########-####-####-####-############)

‘VM NAME’: Failed to open attachment ‘Drive Letter:\path\Virtual Hard drivers\VMNAME_########-####-####-####-############.vhd’. Error: ‘A device attached to the system is not functioning’ (0x8007001F) (Virtual Machine ID: ########-####-####-####-############)

This Microsoft KB article described the symptom: http://support.microsoft.com/kb/2013544.  However, the suggested solution did not solve the problem.

Cause

The KB article describes the cause as follows:

There is a timing issue with FSDepends.sys and with VHDMP.sys. This timing issue occurs when certain backup programs are installed on computers that are running Windows Server 2008. By default, the FSDepends.sys start value in the registry is set to Manual. When any third-party backup software loads its tape device driver, the software can sometimes result in FSDepends.sys and VHDMP.sys not initializing correctly.

Solution

The KB article suggests the following solution:

To work around these problems, FSDepends.sys should be set to a start value of Boot (0x0).

  • Navigate the registry to the following key: “HKLM\SYSTEM\CurrentControlSet\Services\FsDepends”
  • Under the “FsDepends” key, change REG_DWORD value “Start” from “3” to “0”

The rest of the solution is to also make the same change for the VHDMP key:

  • Navigate the registry to the following key: “HKLM\SYSTEM\CurrentControlSet\Services\VHDMP”
  • Change the contained REG_DWORD value “Start” from “3” to “0”

 

Hide Drives in Safely Remove Hardware

Navigate to the following registry path:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\msahci

Create new keys:

Controller0\Channel0
Controller0\Channel1

… and so on.

For channel you wish to keep from showing up in “Safely Remove Hardware”, create a DWORD named “TreatAsInternalPort” and set the value to 1.

Source

Bookmarklet: Dump MEGA localStorage

This is a bookmarklet that will dump the HTML5 localStorage object into a bookmarklet that you can then import into another browser.

javascript:(function(){
var key; 
var undump = ""; 
for (var i = 0, len = localStorage.length; i < len; i++){ 
key = localStorage.key(i); 
undump += "localStorage.setItem('" + key + "','" + localStorage.getItem(key) + "'); "; } 
console.log(undump);
window.prompt("Bookmarklet", "javascript:(function(){ localStorage.clear(); " + undump + "}());" );  
}());


Display Server Alias in Network Browser

“Network Places” is built from information obtained by the subnet master
browsers, which get and maintain their browse list by listening for
NetBIOS broadcasts and via periodic communication with the Domain Master
Browser (the PDC-E).

Add a REG_MULTI_SZ value named OptionalNames to the HKLM\System
\CurrentControlSet\Services\lanmanserver\parameters key and put both
names in it. Either restart the server service or reboot the system and
both names *should* show up. Eventually. (~12 minutes by default.)

Credit: Wayne Tilton

Ubuntu 10.04.2 Live USB

Created USB using Universal-USB-Installer-1.8.3.7.exe and ubuntu-10.04.2-desktop-i386.iso.

Edited /syslinux/text.cfg on USB as follows:
default live
label live
menu label ^Run Ubuntu from this USB
kernel /casper/vmlinuz
append noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz splash --
label live-nvidia
menu label Run Ubuntu (NVidia)
kernel /casper/vmlinuz
append noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz nomodeset --
label live-vesa
menu label Run Ubuntu (VESA)
kernel /casper/vmlinuz
append noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz xforcevesa --
label live-install
menu label ^Install Ubuntu on a Hard Disk
kernel /casper/vmlinuz
append cdrom-detect/try-usb=true file=/cdrom/preseed/ubuntu.seed boot=casper only-ubiquity initrd=/casper/initrd.lz splash --
label memtest
menu label Test ^memory
kernel /install/mt86plus
label hd
menu label ^Boot from first hard disk
localboot 0x80

 

Busybox on Rooted HTC Desire w/ Android 2.2 Froyo

Install Titanium Backup and use it to install busybox.
Boot into Recovery. If using clockworkmod, be sure to mount system and data. Using the Android SDK, from the command line, run this stuff:

adb shell
cp /data/data/com.keramidas.TitaniumBackup/files/busybox /system/xbin/busybox
chmod 755 /system/xbin/busybox
./busybox --install -s /system/xbin

Enable External Mail on Ubuntu

First, install the appropriate packages:

sudo apt-get install mailutils

Configure Exim for external mail:

sudo dpkg-reconfigure exim4-config

Options:

  • mail sent by smarthost; no local mail
  • FQDN of the system
  • 127.0.0.1  (This will prevent external use of the server to send mail.)
  • localhost; hostname
  • FQDN of the system
  • External (ISP) SMTP server
  • Dial-on-Demand? No
  • Split config? No
  • Root/postmaster recipient: (enter the email address you wish to receive messages sent to root/postmaster on the system).

The root/postmaster recipient is stored in /etc/aliases

The Exim configuration is stored in /etc/exim4/update-exim4.conf.conf.  To apply configuration manually changed in this file, run:

sudo update-exim4.conf
sudo /etc/init.d/exim4 restart

Actual Exim configuration is stored in /var/lib/exim4/config.autogenerated. Don’t edit this file directly.

This was tested on Ubuntu 10.04 (Lucid)